If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.
Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.
Output Specification:
For each test case, print in a line “YES” if the two numbers are treated equal, and then the number in the standard form “0.d1…dN*10^k” (d1>0 unless the number is 0); or “NO” if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.
Note: Simple chopping is assumed without rounding.
Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3
题目大意:给出两个数,问将它们写成保留N位小数的科学计数法后是否相等。如果相等,输出YES,同时输出他们的科学记数法表示的方式;如果不相等输出NO,分别输出他们的科学计数法表示方式。
注意:无需四舍五入。
分析:将两个数以字符串的形式输入,如果他们有前导0则删除前导0。删除前导0之后会碰到两种情况:如果是小数点,说明这个数小于1,接下来将小数点删除,如果删除小数点之后的那个数值是0需要把0删除同时令指数相应地减1,直到不为0为止;如果不是小数点的话,则在while循环当中去寻找后面可能存在的小数点,在没有找到小数点之前,字符串下标每向后移动一位,指数便加1。跳出while循环之后,如果字符串下标小于字符串此时的长度,说明找到了小数点,删除小数点。在这两种情况都处理完之后,如果字符串的长度为0,则说明这个数为0。接下来令数组下标为0,在while循环中只要题目要求的精度没有达到就不断执行。而只要字符串此时的下标还小于字符串的长度就直接把数字加到新字符串的末尾,否则就添0。
#include "stdafx.h"
#include<iostream>
#include<stdlib.h>
#include<string>
using namespace std;
int n;//有效位数
string deal(string s, int &e) {
int k = 0;//s的下标
while (s.length() > 0 && s[0] == '0') {
s.erase(s.begin());//删除前导0
}
if (s[0] == '.') {//删除前导0之后是小数点,说明s是小于1的小数
s.erase(s.begin());//删除小数点
while (s.length() > 0 && s[0] == '0') {
s.erase(s.begin());//删除小数点后非0位前的所有0
e--;//每删除一个0,指数就减1
}
}else {//删除前导0之后不是小数点,则找到后面的小数点删除
while (k < s.length() && s[k] != '.') {
k++;
e++;//只要没碰到小数点指数就加1
}
if (k < s.length())
s.erase(s.begin() + k);//如果此时k<s.length()则说明碰到了小数点,删除小数点
}
if (s.length() == 0) e = 0;//删除前导0之后s的长度变为0,说明这个数是0
int num = 0;
k = 0;
string res;
while (num < n) {
if (k < s.length()) res += s[k++];//只要还有数字,就加到res的末尾
else res += '0';//否则就在res的末尾加0
num++;//精度加1
}
return res;
}
int main() {
string s1, s2, s3, s4;
cin >> n >> s1 >> s2;
int e1 = 0, e2 = 0;
s3 = deal(s1, e1);
s4 = deal(s2, e2);
if (s3 == s4&&e1 == e2)
cout << "YES 0." << s3 << "*10^" << e1 << endl;
else
cout << "NO 0." << s3 << "*10^" << e1 << " 0." << s4 << "*10^"<< e2 << endl;
system("pause");
return 0;
}