EchoDemo's Blogs

PAT A1032 Sharing

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, “loading” and “being” are stored as showed in Figure 1.You are supposed to find the starting position of the common suffix (e.g. the position of “i” in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output “-1” instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890

Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1

题目大意:求两个存储英语单词的字母链表的首个公共结点的地址。如果没有,就输出-1

分析:本题是在链表当中寻找起始公共节点的位置且地址的范围比较小,此处选择使用静态链表来处理。用结构体数组进行存储,node[i]表示地址为i的结点,data表示值,next为下一个结点的地址,flag表示第一条链表有没有该结点。遍历第一条链表,将访问过的结点的flag都标记为true,当遍历第二条结点的时候,如果遇到了true的结点就输出并结束程序,没有遇到就输出-1。

#include "stdafx.h"
#include<iostream>
#include<stdlib.h>
using namespace std;

struct Node {
    char data;
    int next;
    bool flag;//用于判断公共节点的初始位置
}node[100010];

void Create(int n) {//创建一个静态链表
    int address, next;
    char data;
    for (int i = 0;i < 100010;i++) {//初始化链表节点的标志为false
        node[i].flag = false;
    }
    for (int i = 0;i < n;i++) {
        cin >> address >> data >> next;
        node[address].data = data;
        node[address].next = next;
    }
}

int main() {
    int x, y, n,i;
    cin >> x >> y >> n;
    Create(n);//创建一个静态链表
    for (i = x;i != -1;i = node[i].next) {//将第一个单词走过的节点的标志位设为true
        node[i].flag = true;
    }
    for (i = y;i != -1;i = node[i].next) {
        if (node[i].flag == true) {
            printf("%5d", i);//如果此时的节点的标志位为true说明是公共节点
            system("pause");
            return 0;
        }
    }
    printf("-1");//否则输出-1
    system("pause");
    return 0;
}
🐶 您的支持将鼓励我继续创作 🐶
-------------本文结束感谢您的阅读-------------