EchoDemo's Blogs

PAT A1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2

此题在一开始写的时候没有注意到当输出系数不为零的个数为0时的情况,故导致格式错误。

#include "stdafx.h"
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
using namespace std;


int main() {
    double a[1001] = { 0.0 }, b[1001] = { 0.0 }, c[1001] = { 0.0 };
    int m, n;
    cin >> m;
    for (int i = 0;i < m;i++) {//初始化第一个多项式
        int j;
        cin >> j;
        cin >> a[j];
        c[j] += a[j];
    }
    cin >> n;
    for (int i = 0;i < n;i++) {//初始化第二个多项式
        int j;
        cin >> j;
        cin >> b[j];
        c[j] += b[j];
    }

    int num = 0;
    for (int i = 0;i < 1001;i++) {//计算系数非零的个数
        if (c[i] != 0) num++;
    }

    cout << num;
    if (num != 0) cout << " ";//这里需要注意

    for (int i = 1000;i >= 0;i--) {
        if (c[i] == 0) continue;
        cout << i << " ";
        printf("%.1f", c[i]);
        num--;
        if (num != 0) cout << " ";
    }
    system("pause");
    return 0;
}
🐶 您的支持将鼓励我继续创作 🐶
-------------本文结束感谢您的阅读-------------